Install Flower#

Python version#

Flower requires at least Python 3.7, but Python 3.8 or above is recommended.

Installe la version stable#

Les versions stables sont disponibles sur PyPI: :

python -m pip install flwr

Pour les simulations qui utilisent le moteur de client virtuel, flwr doit être installé avec l’option simulation: :

python -m pip install flwr[simulation]

Vérifie l’installation#

La commande suivante peut être utilisée pour vérifier si Flower a été installé avec succès. Si tout a fonctionné, la version de Flower devrait être imprimée sur la ligne de commande: :

python -c "import flwr;print(flwr.__version__)"
1.5.0

Options d’installation avancées#

Installer la version pre-release#

Les nouvelles versions (éventuellement instables) de Flower sont parfois disponibles en tant que versions préliminaires (alpha, bêta, release candidate) avant que la version stable n’arrive : :

python -m pip install -U --pre flwr

Pour les simulations qui utilisent le moteur de client virtuel, les versions de flwr doivent être installées avec l’option simulation: :

python -m pip install -U --pre flwr[simulation]

Installer la version nightly#

Les dernières modifications (potentiellement instables) de Flower sont disponibles sous forme de versions nocturnes: :

python -m pip install -U flwr-nightly

Pour les simulations qui utilisent le moteur de client virtuel, flwr-nightly doit être installé avec l’option simulation: :

python -m pip install -U flwr-nightly[simulation]